// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^\[]+").unwrap();
let string = "Order[NN(STTS)]
523:10[CARD(STTS)]
Euro12[NN(STTS)]";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}