#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(la)(la[l]?)*(f.*)"
Local $sString = "lalalalalalaffffff"
Local $sSubst = "$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)