import Foundation
let pattern = #"(la)(la[l]?)*(f.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"lalalalalalaffffff"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)