$re = '/(la)(la[l]?)*(f.*)/';
$str = 'lalalalalalaffffff';
$subst = "$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;