# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\/justicefor\\/(.*)\\/.*(\.\w+)/\1\2/gm;t' <<< "/justicefor/404/1nirmala5.jpg"