re = /\/justicefor\/(.*)\/.*(\.\w+)/m
str = '/justicefor/404/1nirmala5.jpg'
subst = '\\1\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result