use strict;
my $str = '/justicefor/404/1nirmala5.jpg';
my $regex = qr/\/justicefor\/(.*)\/.*(\.\w+)/mp;
my $subst = '\\1\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";