package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s) *({{< ?file(?:-excerpt)? [^>]* ?>}}.*?{{< ?/ ?file(?:-excerpt)? ?>}})`)
var str = ` {{< file "hello.go" go >}}
package main
import "fmt"
func main() {
fmt.Printf("hello, world\n")
}
{{</ file >}}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}