import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s) *(\\{\\{< ?file(?:-excerpt)? [^>]* ?>\\}\\}.*?\\{\\{< ?/ ?file(?:-excerpt)? ?>\\}\\})";
final String string = " {{< file \"hello.go\" go >}}\n"
+ "package main\n\n"
+ "import \"fmt\"\n\n"
+ "func main() {\n"
+ " fmt.Printf(\"hello, world\\n\")\n"
+ "}\n"
+ "{{</ file >}}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}