const regex = new RegExp('(?s) *({{< ?file(?:-excerpt)? [^>]* ?>}}.*?{{< ?/ ?file(?:-excerpt)? ?>}})', 'g')
const str = ` {{< file "hello.go" go >}}
package main
import "fmt"
func main() {
fmt.Printf("hello, world\\n")
}
{{</ file >}}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}