re = /(?s) *({{< ?file(?:-excerpt)? [^>]* ?>}}.*?{{< ?\/ ?file(?:-excerpt)? ?>}})/
str = ' {{< file "hello.go" go >}}
package main
import "fmt"
func main() {
fmt.Printf("hello, world\\n")
}
{{</ file >}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end