$re = '`(?s) *({{< ?file(?:-excerpt)? [^>]* ?>}}.*?{{< ?/ ?file(?:-excerpt)? ?>}})`';
$str = ' {{< file "hello.go" go >}}
package main
import "fmt"
func main() {
fmt.Printf("hello, world\\n")
}
{{</ file >}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);