import re
regex = re.compile(r"(?s) *({{< ?file(?:-excerpt)? [^>]* ?>}}.*?{{< ?/ ?file(?:-excerpt)? ?>}})")
test_str = (" {{< file \"hello.go\" go >}}\n"
"package main\n\n"
"import \"fmt\"\n\n"
"func main() {\n"
" fmt.Printf(\"hello, world\\n\")\n"
"}\n"
"{{</ file >}}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")