# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/®(?=[^<>]*(?:<[^>]*>[^<]*)*$)/<sup>®<\/sup>/gim;t' <<< "<img title=\"Copyright replacement incorrect ®\" src=\"/fileadmin/filexyz.png\">
<h1>Copyright replacement correct: ®</h1>
Also correct replacement here: ®
"