$re = '/®(?=[^<>]*(?:<[^>]*>[^<]*)*$)/im';
$str = '<img title="Copyright replacement incorrect ®" src="/fileadmin/filexyz.png">
<h1>Copyright replacement correct: ®</h1>
Also correct replacement here: ®
';
$subst = "<sup>®</sup>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;