re = /®(?=[^<>]*(?:<[^>]*>[^<]*)*$)/im
str = '<img title="Copyright replacement incorrect ®" src="/fileadmin/filexyz.png">
<h1>Copyright replacement correct: ®</h1>
Also correct replacement here: ®
'
subst = '<sup>®</sup>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result