using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"®(?=[^<>]*(?:<[^>]*>[^<]*)*$)";
string substitution = @"<sup>®</sup>";
string input = @"<img title=""Copyright replacement incorrect ®"" src=""/fileadmin/filexyz.png"">
<h1>Copyright replacement correct: ®</h1>
Also correct replacement here: ®
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}