# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/0([0-9]{2})/$1/gm;t' <<< "05-09-014
05-08-01
016-06-06"