const regex = /0([0-9]{2})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('0([0-9]{2})', 'gm')
const str = `05-09-014
05-08-01
016-06-06`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);