package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)0([0-9]{2})`)
var str = `05-09-014
05-08-01
016-06-06`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}