use strict;
my $str = '05-09-014
05-08-01
016-06-06';
my $regex = qr/0([0-9]{2})/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";