#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)0([0-9]{2})"
Local $sString = "05-09-014 " & @CRLF & _
"05-08-01 " & @CRLF & _
"016-06-06"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)