using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"0([0-9]{2})";
string substitution = @"$1";
string input = @"05-09-014
05-08-01
016-06-06";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}