#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^mongodb:\/\/[^\/\,]+:{1}[^\/\,]*@{1}.*$"
Local $sString = "mongodb://username:pas5w0rd@db1.example.net,app:user@db2.example.net:2500/databaseName?replicaSet=test&connectTimeoutMS=300000" & @CRLF & _
"" & @CRLF & _
"mongodb://db1.example.net, username:pas5w0rd@db2.example.net:2500/databaseName?replicaSet=test&connectTimeoutMS=300000" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")