import re
regex = re.compile(r"^mongodb:\/\/[^\/\,]+:{1}[^\/\,]*@{1}.*$", flags=re.MULTILINE)
test_str = ("mongodb://username:pas5w0rd@db1.example.net,app:user@db2.example.net:2500/databaseName?replicaSet=test&connectTimeoutMS=300000\n\n"
"mongodb://db1.example.net, username:pas5w0rd@db2.example.net:2500/databaseName?replicaSet=test&connectTimeoutMS=300000\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")