const regex = /^mongodb:\/\/[^\/\,]+:{1}[^\/\,]*@{1}.*$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^mongodb:\\\/\\\/[^\\\/\\,]+:{1}[^\\\/\\,]*@{1}.*$', 'mg')
const str = `mongodb://username:pas5w0rd@db1.example.net,app:user@db2.example.net:2500/databaseName?replicaSet=test&connectTimeoutMS=300000
mongodb://db1.example.net, username:pas5w0rd@db2.example.net:2500/databaseName?replicaSet=test&connectTimeoutMS=300000
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}