re = /^mongodb:\/\/[^\/\,]+:{1}[^\/\,]*@{1}.*$/m
str = 'mongodb://username:pas5w0rd@db1.example.net,app:user@db2.example.net:2500/databaseName?replicaSet=test&connectTimeoutMS=300000
mongodb://db1.example.net, username:pas5w0rd@db2.example.net:2500/databaseName?replicaSet=test&connectTimeoutMS=300000
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end