use strict;
my $str = 'mongodb://username:pas5w0rd@db1.example.net,app:user@db2.example.net:2500/databaseName?replicaSet=test&connectTimeoutMS=300000
mongodb://db1.example.net, username:pas5w0rd@db2.example.net:2500/databaseName?replicaSet=test&connectTimeoutMS=300000
';
my $regex = qr/^mongodb:\/\/[^\/\,]+:{1}[^\/\,]*@{1}.*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}