// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^mongodb:\/\/[^\/\,]+:{1}[^\/\,]*@{1}.*$").unwrap();
let string = "mongodb://username:pas5w0rd@db1.example.net,app:user@db2.example.net:2500/databaseName?replicaSet=test&connectTimeoutMS=300000
mongodb://db1.example.net, username:pas5w0rd@db2.example.net:2500/databaseName?replicaSet=test&connectTimeoutMS=300000
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}