#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)( " & @CRLF & _
" (\s*[a-zA-Z]\w*\s*) " & @CRLF & _
" : " & @CRLF & _
" ( " & @CRLF & _
" " & @CRLF & _
" (\s* " & @CRLF & _
" ([a-fA-F0-9])+| " & @CRLF & _
" ("(?:[^"\\]|\\.)*")" & @CRLF & _
" \s*)| " & @CRLF & _
" (\s*,\s*) " & @CRLF & _
" )+ " & @CRLF & _
" \s*;\s* " & @CRLF & _
")+ " & @CRLF & _
"\s*.$" & @CRLF & _
""
Local $sString = " ident1:1fabcd,dfece,"teste de string",0;" & @CRLF & _
"ident2: 3984, a763af;" & @CRLF & _
"ident3 : 0 , "string com \" (aspas)" , faca , da0e , 0 ; " & @CRLF & _
"" & @CRLF & _
"."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")