// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?x)(
(\s*[a-zA-Z]\w*\s*)
:
(
(\s*
([a-fA-F0-9])+|
("(?:[^"\\]|\\.)*")
\s*)|
(\s*,\s*)
)+
\s*;\s*
)+
\s*.$
"#).unwrap();
let string = " ident1:1fabcd,dfece,\"teste de string\",0;
ident2: 3984, a763af;
ident3 : 0 , \"string com \\\" (aspas)\" , faca , da0e , 0 ;
.";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}