import re
regex = re.compile(r"""
(
(\s*[a-zA-Z]\w*\s*)
:
(
(\s*
([a-fA-F0-9])+|
("(?:[^"\\]|\\.)*")
\s*)|
(\s*,\s*)
)+
\s*;\s*
)+
\s*.$
""", flags=re.VERBOSE)
test_str = (" ident1:1fabcd,dfece,\"teste de string\",0;\n"
"ident2: 3984, a763af;\n"
"ident3 : 0 , \"string com \\\" (aspas)\" , faca , da0e , 0 ; \n\n"
".")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")