package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(
(\s*[a-zA-Z]\w*\s*)
:
(
(\s*
([a-fA-F0-9])+|
("(?:[^"\\]|\\.)*")
\s*)|
(\s*,\s*)
)+
\s*;\s*
)+
\s*.$
`)
var str = ` ident1:1fabcd,dfece,"teste de string",0;
ident2: 3984, a763af;
ident3 : 0 , "string com \" (aspas)" , faca , da0e , 0 ;
.`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}