import Foundation
let pattern = #"""
(
(\s*[a-zA-Z]\w*\s*)
:
(
(\s*
([a-fA-F0-9])+|
("(?:[^"\\]|\\.)*")
\s*)|
(\s*,\s*)
)+
\s*;\s*
)+
\s*.$
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"""
ident1:1fabcd,dfece,"teste de string",0;
ident2: 3984, a763af;
ident3 : 0 , "string com \" (aspas)" , faca , da0e , 0 ;
.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}