use strict;
my $str = ' ident1:1fabcd,dfece,"teste de string",0;
ident2: 3984, a763af;
ident3 : 0 , "string com \\" (aspas)" , faca , da0e , 0 ;
.';
my $regex = qr/(
(\s*[a-zA-Z]\w*\s*)
:
(
(\s*
([a-fA-F0-9])+|
("(?:[^"\\]|\\.)*")
\s*)|
(\s*,\s*)
)+
\s*;\s*
)+
\s*.$
/xp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}