using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(
(\s*[a-zA-Z]\w*\s*)
:
(
(\s*
([a-fA-F0-9])+|
(""(?:[^""\\]|\\.)*"")
\s*)|
(\s*,\s*)
)+
\s*;\s*
)+
\s*.$
";
string input = @" ident1:1fabcd,dfece,""teste de string"",0;
ident2: 3984, a763af;
ident3 : 0 , ""string com \"" (aspas)"" , faca , da0e , 0 ;
.";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}