#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)((?:\w+\s)?blue(?:\s\w+)?)"
Local $sString = "My blue car # What I exactly want." & @CRLF & _
"the blue jacket" & @CRLF & _
"their blue phone" & @CRLF & _
"a blue alien" & @CRLF & _
"End sentence. Blue is" & @CRLF & _
"is blue." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")