$re = '/(?i)((?:\w+\s)?blue(?:\s\w+)?)/';
$str = 'My blue car # What I exactly want.
the blue jacket
their blue phone
a blue alien
End sentence. Blue is
is blue.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);