// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)((?:\w+\s)?blue(?:\s\w+)?)").unwrap();
let string = "My blue car # What I exactly want.
the blue jacket
their blue phone
a blue alien
End sentence. Blue is
is blue.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}