using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)((?:\w+\s)?blue(?:\s\w+)?)";
string input = @"My blue car # What I exactly want.
the blue jacket
their blue phone
a blue alien
End sentence. Blue is
is blue.
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}