import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)((?:\\w+\\s)?blue(?:\\s\\w+)?)";
final String string = "My blue car # What I exactly want.\n"
+ "the blue jacket\n"
+ "their blue phone\n"
+ "a blue alien\n"
+ "End sentence. Blue is\n"
+ "is blue.\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}