package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)((?:\w+\s)?blue(?:\s\w+)?)`)
var str = `My blue car # What I exactly want.
the blue jacket
their blue phone
a blue alien
End sentence. Blue is
is blue.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}