re = /(?i)((?:\w+\s)?blue(?:\s\w+)?)/
str = 'My blue car # What I exactly want.
the blue jacket
their blue phone
a blue alien
End sentence. Blue is
is blue.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end