#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<figure class="post-image left">\s*<a href="([^"]+)"><img src="([^"]+)"[^l]+lt="([^"]+)" /></a>\s*</figure>"
Local $sString = "<figure class="post-image left">" & @CRLF & _
" <a href="http://toonitalia.altervista.org/fantasia-2000/"><img src="http://toonitalia.altervista.org/wp-content/uploads/2015/10/Fantasia-2000.jpg" width="200" height="200" alt="Fantasia 2000" /></a>" & @CRLF & _
" </figure>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")