using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<figure class=""post-image left"">\s*<a href=""([^""]+)""><img src=""([^""]+)""[^l]+lt=""([^""]+)"" /></a>\s*</figure>";
string input = @"<figure class=""post-image left"">
<a href=""http://toonitalia.altervista.org/fantasia-2000/""><img src=""http://toonitalia.altervista.org/wp-content/uploads/2015/10/Fantasia-2000.jpg"" width=""200"" height=""200"" alt=""Fantasia 2000"" /></a>
</figure>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}