const regex = new RegExp('<figure class="post-image left">\\s*<a href="([^"]+)"><img src="([^"]+)"[^l]+lt="([^"]+)" /></a>\\s*</figure>', '')
const str = `<figure class="post-image left">
<a href="http://toonitalia.altervista.org/fantasia-2000/"><img src="http://toonitalia.altervista.org/wp-content/uploads/2015/10/Fantasia-2000.jpg" width="200" height="200" alt="Fantasia 2000" /></a>
</figure>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}