// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<figure class="post-image left">\s*<a href="([^"]+)"><img src="([^"]+)"[^l]+lt="([^"]+)" /></a>\s*</figure>"#).unwrap();
let string = "<figure class=\"post-image left\">
<a href=\"http://toonitalia.altervista.org/fantasia-2000/\"><img src=\"http://toonitalia.altervista.org/wp-content/uploads/2015/10/Fantasia-2000.jpg\" width=\"200\" height=\"200\" alt=\"Fantasia 2000\" /></a>
</figure>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}