import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<figure class=\"post-image left\">\\s*<a href=\"([^\"]+)\"><img src=\"([^\"]+)\"[^l]+lt=\"([^\"]+)\" /></a>\\s*</figure>";
final String string = "<figure class=\"post-image left\">\n"
+ " <a href=\"http://toonitalia.altervista.org/fantasia-2000/\"><img src=\"http://toonitalia.altervista.org/wp-content/uploads/2015/10/Fantasia-2000.jpg\" width=\"200\" height=\"200\" alt=\"Fantasia 2000\" /></a>\n"
+ " </figure>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}