import re
regex = re.compile(r"<figure class=\"post-image left\">\s*<a href=\"([^\"]+)\"><img src=\"([^\"]+)\"[^l]+lt=\"([^\"]+)\" /></a>\s*</figure>")
test_str = ("<figure class=\"post-image left\">\n"
" <a href=\"http://toonitalia.altervista.org/fantasia-2000/\"><img src=\"http://toonitalia.altervista.org/wp-content/uploads/2015/10/Fantasia-2000.jpg\" width=\"200\" height=\"200\" alt=\"Fantasia 2000\" /></a>\n"
" </figure>")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")