$re = '/<figure class="post-image left">\s*<a href="([^"]+)"><img src="([^"]+)"[^l]+lt="([^"]+)" /></a>\s*</figure>/';
$str = '<figure class="post-image left">
<a href="http://toonitalia.altervista.org/fantasia-2000/"><img src="http://toonitalia.altervista.org/wp-content/uploads/2015/10/Fantasia-2000.jpg" width="200" height="200" alt="Fantasia 2000" /></a>
</figure>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);